WordPress Vulnerability Audits Are Important – Here’s Why

Published on June 8, 2019
/ Article By Jimmy Bisenius

Recently when Cary local neurofeedback therapy service provider MyBrainDr reached out regarding a site outage, we knew that an extensive audit was the first step in diagnosing the issue and creating an appropriate plan of action to get the site live.

 

After completing the audit, we found that their outage had been caused by a vulnerability in an outdated and unused third party plugin. Although you may not realize, this is far too common as the chances are that if you use WordPress, you will have at least one third-party plugin or theme installed & activated at any given time.

 

We were also able to identify several other vulnerabilities due to outdated plugins, one most notable being the recent YoastSEO permissions bug.

 

With a retainer from Neutron Creative, we can perform an extensive audit on your existing web property and ensure your site’s long-term security. If you’re interested in learning more, fill out the form below and we’d be happy to help!